MagicPicker and new Photoshop CC 2015/Illustrator CC 2015

Today Adobe issued an upgrade to their Creative Cloud. Namely Photoshop and Illustrator have been updated to version CC 2015. And I receive questions whether MagicPicker is compatible with the new platform. MagicPicker 4 was tested and totally works as is with the new Adobe’s products – Photoshop CC 2015 and Illustrator CC 2015. In most cases you don’t have to do anything after CC 2015 upgrade.

You don’t need to upgrade or reinstall, just please make sure you have the latest version of Adobe Extension Manager CC (you can always install it from Adobe Creative Cloud app).

MagicPicker in Photoshop CC 2015 and Illustrator CC 2015
MagicPicker in Photoshop CC 2015 and Illustrator CC 2015

There’s even more to it – some reported that Compact Mode didn’t work in the new CC 2014 software on selected system configurations. Seems there was a conflict that Adobe has resolved in the new versions of Photoshop/Illustrator. So if you still see your Compact Mode grayed out

or

If you face any issues with MagicPicker disappearing from the Extensions menu in new CC 2015 software – try to reinstall or update Adobe Extension Manager CC and then reinstalling MagicPicker.

Installing MagicPicker 4 with Adobe Extension Manager CC is easy and works the same on both platforms – Mac and PC (Windows):

1) Make sure your have the Adobe Extension Manager CC installed – go to your Adobe Creative Cloud, locate Adobe Extension Manager and click Install or Upgrade
2) Run  Adobe Extension Manager
3) Choose File -> Install Extension
4) Locate MagicPicker4.zxp and follow the installation steps

P.S. MagicPicker is still compatible with Photoshop & Illustrator CS3, CS4, CS5, CS6, CC, CC2014.

Download MagicPicker color wheel for Photoshop & Illustrator

Upgrade from older MagicPicker to version 4

8 thoughts on “MagicPicker and new Photoshop CC 2015/Illustrator CC 2015”

  1. Hello~
    I was bought this program Magic picker today , and try to install. But I receive the error massage This extention need to Illustrator ver15.0 so can’t install it.

    Now I’m using Photoshop CC2015 and Window7

    Oh, I not good at English, so my word is little bit weird. sorry about that. Just solve this problem Plz

  2. Hi, I boufht Magic Picker, and I have the same problem: ” This extention need to Illustrator ver15.0 so can’t install it.”.

    I already installed your Manager version, but a message says “No Adobe Programs Found”.

  3. Can I just have a refund? I have not installed and uninstalled your extension manager and adobes and none of it will work. I have no clue why the adobe extension manager keeps telling me they can’t install it because i need to run illustrator 15.0 or higher and I have version 19. This is grating on me in a bad way, I’ve lost an hour of work so far

  4. This message is a bug of Adobe Extension Manager, it’s easy to fix. If you haven’t done so yet please contact our support by email and tell us your full Photoshop’s version from the About box. You’ll be helped!

  5. I have old PS 6.0. Will MagicPicker work with this on Windows 10, or more importantly, will MagicPicker work standalone, without PS ???

Leave a Reply

Your email address will not be published. Required fields are marked *